微信小程序之小程序开发常见的问题

时间:2018-05-13来源:网站源码库 作者:源码库 文章热度:

有时候微信版本太低,有些功能可能不支持,例如复制粘贴,在微信的基础库1.0.0就不支持,那么如何做呢?就是判断一下,然后给一个提示。

这是一个js方法,用来调用复制的API
 

  1. copy: function () { 
  2.     if (wx.setClipboardData) {             //判断是否可以调用此API 
  3.       wx.setClipboardData({               //调用复制的API 
  4.         data: '我复制的内容',             //要复制的内容 
  5.         success: function (res) { 
  6.           wx.getClipboardData({ 
  7.             success: function (res) { 
  8.               console.log(res.data) // data 
  9.               wx.showToast({              //打印一个提示,类似Android的吐司 
  10.                 title: '复制成功'
  11.               }) 
  12.             } 
  13.           }) 
  14.         } 
  15.       }) 
  16.     } else { 
  17.       wx.showModal({                        //弹出一个对话框 
  18.         title: '提示'
  19.         content: '您的微信版本太低,暂时不能使用此版本'
  20.       }) 
  21.     } 
  22.   } 

注:相关教程知识阅读请移步到微信小程序开发频道。
相关微信小程序开发
热门标签

微信小程序开发Rss订阅微信小程序开发搜索